CML向け base configure¶
導入の方法¶
購入後のMyAccountからSoftWare Downloadに飛ぶ。通常の方法でDownloadページに飛んでもダメだった。
EditConfigの書き方¶
nxos9k¶
conf t
no ip domain-lo
feature telnet
hostname nexus-spine
interface mgmt0
duplex full
vrf member management
ip address 192.168.101.210/24
vrf context management
ip route 0.0.0.0/0 192.168.101.1
line vty
no shut
設計¶
- external connecterはBridgeにする
xRV¶
hostname r2
vrf Mgmt-intf
address-family ipv4 unicast
!
address-family ipv6 unicast
!
interface MgmtEth0/0/CPU0/0
description mgmt
vrf Mgmt-intf
ipv4 address 10.10.20.11 255.255.255.0
no shutdown
!
router static
vrf Mgmt-intf
address-family ipv4 unicast
0.0.0.0/0 10.10.20.254
!
control-plane
management-plane
inband
interface all
allow all
telnet vrf Mgmt-intf ipv4 server max-servers 100
line default
vty-pool default 0 4 line-template default
domain name cisco
ssh server v2
ssh server vrf Mgmt-intf ipv4
commit
end
crypto key generate rsa
ping 10.10.20.254 vrf Mgmt-intf
csr1000v¶
conf t
hostname r1
logg console
vrf definition Mgmt-intf
address-family ipv4
address-family ipv6
ip domain name cisco
no ip domain lookup
interface GigabitEthernet20
vrf forwarding Mgmt-intf
ip address 10.10.20.21 255.255.255.0
no shutdown
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.10.20.254
line vty 0 4
exec-timeout 720 0
login local
transport input telnet ssh
ip ssh server algorithm authentication password
crypt key gen rsa
nexus9k¶
conf t
no ip domain-lo
feature telnet
interface mgmt0
duplex full
vrf member management
ip address 10.10.20.31/24
vrf context management
ip route 0.0.0.0/0 10.10.20.254
line vty
no shut
Cumulus¶
nv set interface eth0 ip address 192.0.2.42/24
nv set interface eth0 ip gateway 192.0.2.1
nv set system hostname cumulus-1
nv set system timezone Asia/Tokyo
nv config apply
nv config save
basic¶
> if up
nv set interface swp7
nv set interface swp7 bridge domain br_default vlan 100
> drop untag
nv set interface swp7 bridge domain br_default untagged none
> untag:
> nv set interface swp7 bridge domain br_default access 10
nv set interface vlan100 ip address 192.168.100.2/24
nv unset interface vlan10 ip address 192.168.100.2/24
nv unset interface swp7 bridge domain br_default vlan 10
nv set bridge domain br_default vlan 100
nv config apply
nv config save